Modules: Zikula Long Term Support

Eingereicht von DemoAdmin am 07. Mär 2010 - 13:26 Uhr

As previously announced [1], we are dropping support from PHP4 in the next feature release of Zikula 1.3.0 which is due near the end of March when Zikula will require at least PHP 5.2.6. One major reasons is that PHP 4 is not longer developed or patched by the PHP development team, and another is that PHP4 severely restricts our ability to move forward and provide an efficient and modern framework.

As part of our modernisation programme we will be releasing a long term support (LTS) release of Zikula. Since Zikula 1.2 is based on PHP4 it makes absolutely no sense to extend the life support of a PHP4 based product to long term. Zikula 1.2 was always meant to be a stepping stone release to modernise the multilingual system. This means the LTS release will have to be Zikula 1.3 which was pegged not only to be upgraded to PHP 5.2.6, but also to include the new zOO subsystem and break much of our restrictive legacy.

We have decided to separate zOO into a separate milestone for release later this year. We are able to bring a lot of new features and improvements to the Zikula 1.3.0 release as promised in the roadmap, just minus the zOO element. We can then comfortably support this as an LTS release. We have also been working very hard behind the scenes to update all the most popular Zikula extensions [2] to work with Gettext under Zikula 1.2.0. These modules will also work with Zikula 1.3.0 without any modification.

We believe this strikes the best balance in supporting legacy while moving forward to provide a competitive framework solution. The new Zikula distribution release will also be based on Zikula 1.3.0 which will come bundled with the most useful extensions. We hope to have this released shortly after the Zikula 1.3 milestone is complete. We will write about the changes in Zikula 1.3 in a future post.

Lastly, no-one likes continual change. After some deliberation on the matter, we have had to review the policy on PHP5 adoption. From Zikula 1.7.0 (slated to introduce zOO) we will move to require PHP 5.3.0. By doing this we will avoid many inevitable future upheavals and simply many core issues which are supported natively by PHP 5.3. PHP 5.3.0 has already been adopted by some internet heavyweights like Zend Framework as the minimum requirement, so we feel confidence in our decision.

Neuen Kommentar hinzufügen
Links
  1. http://community.zikula.org/module-News-display-sid-2999.htm
  2. http://community.zikula.org/module-Extensions-view-comptype-1.htm