Newsbeiträge » Modules

Zikula Long Term Support

Eingereicht von DemoAdmin am 07. Mär 2010 - 13:26 Uhr

As previously announced, we are dropping support from PHP4 in the next feature release of Zikula 1.3.0 which is due near the end of March when Zikula will require at least PHP 5.2.6. One major reasons is that PHP 4 is not longer developed or patched by the PHP development team, and another is that PHP4 severely restricts our ability to move forward and provide an efficient and modern framework.

As part of our modernisation programme we will be releasing a long term support (LTS) release of Zikula. Since Zikula 1.2 is based on PHP4 it makes absolutely no sense to extend the life support of a PHP4 based product to long term. Zikula 1.2 was always meant to be a stepping stone release to modernise the multilingual system. This means the LTS release will have to be Zikula 1.3 which was pegged not only to be upgraded to PHP 5.2.6, but also to include the new zOO subsystem and break much of our restrictive legacy.