Newsbeiträge » Zikula

Zikula Core 1.3.0

Eingereicht von demoadmin am 21. Nov 2011 - 15:22 Uhr
Bild 0 für Zikula Core 1.3.0

Die Entwicklung von Zikula Core 1.3.0 (Build #3168) ist abgeschlossen. Nach zwei Beta-Versionen, einer Preview-Version und sechs Release Canidates steht der neue Entwicklungszweig nun der Öffentlichkeit zur Verfügung. Trotz der Fertigstellung handelt es sich hier nicht unmittelbar um eine offizielle Produktankündigung. Eingefleischte Fans wissen wahrscheinlich schon, dass das Release schon längst fertiggestellt ist. Dennoch fehlen auf allen Seiten offizielle Ankündigungen. Der Grund ist, dass die zugrundeliegende Infrastruktur noch nicht angepasst ist. Die ExtDB, das Übersetzungsportal (Pootle) und diverse Skripte müssten enorm überarbeitet werden. Wie jedoch halboffiziell zu erfahren war, wird ein neues System entwickelt. Es soll sich um eine Art "AppStore" handeln, der aber sicherlich noch einen anderen Namen bekommt.


Neuigkeiten zu Zikula 1.3.0

Eingereicht von DemoAdmin am 04. Mai 2010 - 10:01 Uhr

Wie schon früher bekannt gegeben wird Zikula 1.3.0 die Basis der "Langzeit Support Zikula Version" (Long Term Support = LTS). Mit dieser Version werden wir endlich viele Altlasten vergangener Tage beseitigt haben die wir schon lange mit rumschleppen. Dadurch werden wir flexibler für neue Möglichkeiten.

1.3.0 an sich bringt eine Menge neuer und spannender Dinge mit sich. Nicht zuletzt das Datenbank Caching. Aber die Hauptänderung ist auf jeden Fall das Beseitigen des Legacy Supports um einen sauberen Übergang der Module die nicht die API benutzen zu forcieren. Modulentwickler können jetzt vollen Nutzen aus PHP5 ziehen.


Demo im neuen Gewand

Eingereicht von DemoAdmin am 19. Mär 2010 - 13:27 Uhr

Diese Demo-Installation wurde aktualisiert und mit vollständig neuen Inhalten versorgt. So sind nicht nur neue Module hinzugefügt worden, sondern die Anzahl an Themes wurde erhöht. Wir wünschen viel Spaß mit den ersten Schritten und hoffentlich gefällt das neue Zikula.

Das deutsche Zikula Supportteam.


Langfristiger Support bei Zikula

Eingereicht von DemoAdmin am 07. Mär 2010 - 09:35 Uhr

Wie bereits angekündigt, wird der Support von PHP4 mit dem nächsten Release von Zikula beendet. Zikula 1.3, das Ende März kommen soll, wird als Mindestanforderung PHP 5.2.6 haben. Hintergrund ist die Tatsache, dass PHP4 von den PHP-Entwicklern weder weiterentwickelt noch gepatcht wird. PHP4 ist tot und es hindert die Zikula-Entwickler, auf moderne Entwicklungsansätze umzustellen. Dafür wird Zikula 1.3 als Long-Term-Support Version (LTS) ausgelegt.


Aus PostNuke wird Zikula

Eingereicht von DemoAdmin am 12. Jun 2008 - 19:40 Uhr

Die Entwickler des PHP-CMS PostNuke haben die Code-Basis komplett überarbeitet und sich ihrem Projekt einen neuen Namen verpasst.